Yaffs采用GPL2许可

发布于 2015-08-27 16:21:22
RTT也采用GPL2,那么是不是可以将之前的Yaffs移植放入RTT代码中了?

查看更多

关注者
0
被浏览
2.3k
2 个回答
bernard
bernard 2015-08-27
RT-Thread实际上是类似RTEMS的GPLv2+,所以和yaffs其实并不兼容。GPLv2+的意思是希望用户如果对RT-Thread进行了修改,需要开源出来,而自己的代码、用于产品的代码,可以选择闭源。

yaffs虽然原来有移植,不过都不可能包含到RT-thread,自己考虑如何进行处理吧

撰写答案

请登录后再发布答案,点击登录

发布
问题

分享
好友

手机
浏览

扫码手机浏览