基于OS_V1.2.0工程升级问题

发布于 2016-07-22 20:48:34
大家好!
目前正在继续维护原先同事基于RT-Thread V1.2.0的项目,在维护项目应用功能的同时,考虑到了OS升级的问题,有如下问题请教:
1)V1.2.0是否适合直接向V1.2.1~1.2.5升级?我的原意是不谋求新增特性,而是希望到V1.2.5系统得到一些内部性能的改善或BUG的修复,所以认为API及组件不变的新版本是有必要采纳的,从V1.2.0到1.2.5是不是就这这种情况?作为使用者,OS内部是否存在问题并不了解。
2)V2.0.0以后的版本我看到新增了组件,因此基于V1.2.0且功能够用的工程是不是就没有必要考虑升级了?
3)V1.2.0到V1.2.5的升级,逐个替换同名目录/文件就可以了吧?

谢谢RT-Thread官方技术专家和广大RT-Thread的用户 [s:154]

查看更多

关注者
0
被浏览
1.8k
3 个回答
aozima
aozima 认证专家 2016-07-23
原来项目已经量产且没什么问题的话,继续保持就好了。

要升级的话,替换同名目录和文件就可以了。
然后就是所有功能都要重新测试。

新项目直接用新的。
bernard
bernard 2016-07-23
对比下,注意下一些bug修复即可

撰写答案

请登录后再发布答案,点击登录

发布
问题

分享
好友