littlewhite2020
littlewhite2020
This guy hasn't written anything yet

注册于 1 year ago

回答
26
文章
1
关注者
0

具体是哪个配置,可以截个图吗?

Studio是哪个版本的?升级到最新版试下,还不行就先删除,再重新下载一下看看

选中工程了吗?日志发出来看下(workspace/.metadata/.log)

rt-thread studio第一次使用是需要联网登录一下的,之后可以不用再登录了,但是在使用的过程中肯定会使用到下载一些资源包,所以最好还是联网使用。
或者,你可以找一台能联网的机器把所需要的资源都下载好之后,拷贝到不能联网的机器上使用

楼上正解,可以手动设置你需要的编码

新建的哪种工程类型?新建rt-thread项目(或者rt-thread nano)才有rt-setting配置界面的.通用项目是没有rt-thread settings的

软件包界面上有显示吗?这个地方
image.png

如果有显示,工程上不显示包,参考一下这个faq?
https://www.rt-thread.org/document/site/rtthread-studio/faq/studio-faq/#packages

最近好像修复了这个问题,你更新一下最新的rt-thread源码,使用scons --dist-ide --project-name=xxx --project-path=xxx 命令生成studio工程

参考下这个pr https://github.com/RT-Thread/rt-thread/pull/4245

你这个是启动studio时报的错吗?电脑什么配置?

这个是提示框,不是错误,需要你先安装latest源码包,后续会优化自动安装依赖

回到
顶部

发布
问题